Satisfi Labs Notice

Incident Report for Satisfi Labs

Resolved

The issue with the Analytics - Request Topics is fully resolved and all services are now fully functional. We will continue to monitor.

If you have any questions, please contact your Client Success Manager or email support@satisfilabs.com.
Posted May 19, 2023 - 12:54 EDT

Investigating

We are currently investigating an issue with the Analytics - Request Topics report that is affecting some users and are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.

If you have any questions please contact your Client Success Manager or email support@satisfilabs.com.
Posted May 19, 2023 - 11:59 EDT
This incident affected: Analytics.