Satisfi Labs Notice

Incident Report for Satisfi Labs

Resolved

The issue with the Satisfi Labs component listed below is fully resolved and all services are now fully functional.

If you have any questions please reach out to the product support team via our request portal or the live chat feature within our dashboard.
Posted Mar 17, 2025 - 10:52 EDT

Investigating

We are currently investigating an issue with the Satisfi Labs component listed below and are working to correct the issue as soon as possible.

Please check back here or subscribe to updates for any changes.

If you have any questions please reach out to the product support team via our request portal or the live chat feature within our dashboard.
Posted Mar 17, 2025 - 07:55 EDT
This incident affected: Analytics.