Satisfi Labs Notice

Incident Report for Satisfi Labs

Resolved

The issue with the Satisfi Labs Responses area of the dashboard is fully resolved and all services are now fully functional.

If you have any questions please reach out to the product support team via our request portal or the live chat feature within our dashboard.
Posted Feb 16, 2024 - 10:46 EST

Investigating

We are currently investigating an issue with the responses area of our dashboard and are working to correct the issue as soon as possible. There is no impact on chat performance.

Please check back here or subscribe to updates for any changes.

If you have any questions please get in touch with the product support team via our request portal or the live chat feature within our dashboard.
Posted Feb 16, 2024 - 09:24 EST
This incident affected: Dashboard.